Część 3. Autouzupełnianie pól z tabeli

Funkcja “WYSZUKAJ.PIONOWO”

Możemy już wybierać z rozwijanej listy naszych dostawców, pora aby reszta pół dotyczących dostawcy uzupełniała nam się na podstawie informacji zapisanych w arkuszu „DANE”. W tym celu dla każdej komórki, która ma te dane zawierać musimy napisać formułę. Wykorzystamy do tego funkcję „Wyszukaj pionowo”. Klikamy lewym przyciskiem myszy na komórkę opisaną jako „NIP” (A16), następnie wybieramy zakładkę „FORMUŁY” i z biblioteki funkcji wybieramy „Wyszuk. i odwoł.” Z listy wybieramy „WYSZUKAJ.PIONOWO” (Rysunek 1).

Rysunek 1.Funkcja “Wyszukaj Pionowo”

Argumenty funkcji

Otwiera się nam nowe okienko. Najpierw musimy ustalić parametr „Szukana_wartość”, w tym celu klikamy na ikonkę po prawej stronie i wybieramy komórkę A15 tam gdzie znajduje się nazwa dostawcy. W polu „Tabela_tablica” klikamy również na ikonę po prawej stronie i przechodzimy do arkusza „DANE” i zaznaczamy zakres A3 do J15, w polu „Nr_indeksu_kolumny” wpisujemy numer kolumny w arkuszu „DANE” w którym znajduje się wartości „NIP”, a więc licząc od prawej w zaznaczonych przez nas kolumnach będzie to „5”. W ten sam sposób edytujemy kolejne komórki zmieniając jedynie „Nr_indeksu_kolumny” na odpowiadający żądanej przez nas wartości. Uzupełniona poprawnie tabelka została przedstawiona na Rysunku 2.

Rysunek 2. Ustawienia wyszukiwania

Teraz po kliknięciu w komórkę A15 na i wybraniu interesującej nas pozycji z listy pole NIP powinno zmienić się na to odpowiadające w tabeli. No właśnie powinno, niestety Excel 2013 ma w tym przypadku ciekawą przypadłość i aby funkcja działała nam za każdym razem prawidłowo musimy zmodyfikować nasz formułę jak poniżej dodając przed końcem nawiasu średnik.

=WYSZUKAJ.PIONOWO(A15;DANE!A3:J15;5;)

Do wyszukanych pozycji można dodać także napis poprzedzający – czyli jeśli chcielibyśmy aby zamiast samego numeru NIP wyświetlił nam się tekst „NIP:” musimy przed komendą „WYSZUKAJ…” w wierszu funkcji dopisać odpowiednią sentencję, poniżej jest przedstawiona pełna formuła.

="NIP: "&WYSZUKAJ.PIONOWO(A15;DANE!A3:J15;5;)

Ten sam efekt chcielibyśmy uzyskać przy ulicy, a więc w komórce A17 wpisujemy:

="ul. "&WYSZUKAJ.PIONOWO(A15;DANE!A3:J15;2;)

W następnym wierszu dobrze byłoby połączyć kod pocztowy z miejscowością, robimy do w analogiczny sposób, przy czy zamiast dodawać napis dodajemy wyszukiwanie nazwy miejscowości. Uzyskujemy w ten sposób poniższą formułę.

=WYSZUKAJ.PIONOWO(A15;DANE!A3:J15;3)&" "&WYSZUKAJ.PIONOWO(A15;DANE!A3:J15;4;)

Pozostałe dane odnośnie telefony, e-maila, transportu, miejsca dostawy czy warunków płatności wypełniamy podobnie jak NIP. Czyli kolejno wpisujemy na pasku funkcji poniższe formuły:

="Transport przez: "&WYSZUKAJ.PIONOWO(A15;DANE!A3:J15;9;)
="Miejsce dostawy:  "&WYSZUKAJ.PIONOWO(A15;DANE!A3:J15;10;)
="Warunki płatności: "&WYSZUKAJ.PIONOWO(A15;DANE!A3:J15;8;)
="tel: "&WYSZUKAJ.PIONOWO(A15;DANE!A3:J15;6;)
="e-mail: "&WYSZUKAJ.PIONOWO(A15;DANE!A3:J15;7;)

Zostały nam jeszcze dwie komórki do zrobienia, a mianowicie telefon osoby zamawiającej (F29) oraz jej e-mail (F30).

="tel. "&WYSZUKAJ.PIONOWO(F28;DANE!M3:O17;2;)

="e-mail: "&WYSZUKAJ.PIONOWO(F28;DANE!M3:O17;3;)

Nasz formularz zyskał już pewną funkcjonalność. Mamy tabelę z danymi oraz autouzupełnanie pól i w wielu przypadkach byłby już wystarczający w tej formie. Jednak w następnej lekcji pójdziemy o krok dalej i wprowadzimy kilka automatyzmów, które pozwolą nam przyspieszyć pracę.

Część 1. Wygląd formularza – coś na dobry początek
Część 2. Rozwijane listy – pola wyboru
Część 3. Autouzupełnianie pól z tabeli
Część 4. Generowanie numeru zamówienia
Część 5. Pierwsze makro
Część 6. Pobieranie nazw plików z katalogu

Dodaj komentarz